Ducati 899 Panigale Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter · #1 ·
Tried to go out today after not using for 4 days and bike being left on a trickle charge. Turned key and got hazard lights flashing , brake light flashing , engine , petrol , oil lights flashing , rpm scale flashing , no gear selection showing and wouldn't fire up starter motor . I called ducati recovery and they sent out a man who couldn't fix it but checked battery levels and said they was fine . Going to call the dealership first thing Monday morning. Anybody else suffered this?
 

·
Registered
Joined
·
77 Posts
Discussion Starter · #3 ·
can always try the ole disconnect the battery for a few hours
Thanks for advice, might try it tonight , failing that my local dealer is picking it up for me after not wanting the breakdown company to recover it ( I've seen them load up my old 848 evo and let's just say not a lot of care goes into it)
 

·
Registered
Joined
·
77 Posts
Discussion Starter · #6 ·
Update : the electrical fault was caused by water that got into some wiring that went into the engine and caused shorting out
On a separate matter whilst it was in at the dealers the mechanic noticed the dreaded engine leak that's plagued some others . Ducati have sent me a complete new engine and are shipping my old engine back to the factory for investigation.
 

·
Registered
Joined
·
692 Posts
Howdy, funny this popped up. I actually had a similar issue not too long ago. I'm pretty sure I got water in somewhere that the bike didn't like when I washed it. My mileage showed 99,999, though when I tried to start it in addition to all the other lights lol!

The solution is to let the bike dry out, the connector will dry out and it will be ok. At least in my case it was.
 
1 - 8 of 8 Posts
Top