Ducati 899 Panigale Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
310 Posts
Discussion Starter · #1 ·
This morning whilst waiting for my bike to warm up I noticed that my right side taillight was not illuminated.

I'm quite sure they both should be, can someone confirm for me?

Brake light is working fine,
 

·
Registered
Joined
·
336 Posts
Both sides are working fine on mine. Tried turning it off and on again? Can you replicate the results? If so take it back to the shop for them to fix it.
 

·
Registered
Joined
·
62 Posts
Yes. Both sides should be on. Then the brake light is like the high beam of the tail lights. There is a 3 prong connector on the left side (when facing forward) of the fixture itself. You'll need to pop off the rear seat and plastics to get to it. Mage sure that is seated properly.

If it is, best bet is to take her in. Maybe the LED's burned out.


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
310 Posts
Discussion Starter · #4 ·
Thanks guys, thought that was the case.

Will try replicate when I leave work tonight and see if still not working.

Hopefully just a loose connection will try have a look tonight, otherwise back into the dealer to get it replaced.
 

·
Registered
Joined
·
310 Posts
Discussion Starter · #5 ·
Still not working tonight when I left for home,

Does anyone know if these are a single wiring loom? Don't wont to pull bike apart if they are, as the brake light works fine still.

Defiantly a trip to the dealer, due for first service in about 150km so not far off.


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
336 Posts
If you can put up with it for another 150kms and both sides light up under braking then just wait till the first service. That's what i'd do.
 

·
Registered
Joined
·
310 Posts
Discussion Starter · #7 ·
If you can put up with it for another 150kms and both sides light up under braking then just wait till the first service. That's what i'd do.
Yeh brakes lights are fine which is the main thing, so I'll give them the heads up when I book in for my service.
 

·
Registered
Joined
·
62 Posts
And yep, it's a single wire loom. Just that 3 prong on the left side. I installed the integrated turn signal one from comp werks so there are 2 additional connections for the turn signals. But the stock one is a single connector.


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
310 Posts
Discussion Starter · #9 ·
And yep, it's a single wire loom. Just that 3 prong on the left side. I installed the integrated turn signal one from comp werks so there are 2 additional connections for the turn signals. But the stock one is a single connector.


Sent from Motorcycle.com Free App
Thank for confirming that for me!
 

·
Registered
Joined
·
4 Posts
I have the same problem the right side went out about 3 weeks ago. still waiting for the dealer to fix it. They had to order a new light, covered under warranty thankfully. I thought it was weird for a led to burn out so quickly so hopefully it was just a defect in the light but when they tried to sell me a comp werks tail light I noticed something weird about that one too. they had an 1199 with a comp werks light installed and after showing it to me and turning the bike off and taking the key out, one of the LEDs in the right tail light remained on for a good 5 minutes. Strange huh??? maybe it's a wiring issue from ducati's side??
 

·
Registered
Joined
·
214 Posts
Get it changed under warranty. I had the same issue. No problems up till now after the change though I didn't find out what exactly was wrong with it. The comp werks light staying on is normal as it is a feature. It's stated in their website.
 

·
Registered
Joined
·
29 Posts
Same thing happened with my tail light as well, a friend riding behind me pointed it out today. The right side running light is out but the brake lights work fine.. Guess I need to say hello again to my local dealer =). Too bad this didn't happen two weeks ago while I was in for my 600 mi service
 

·
Registered
Joined
·
1,841 Posts
I have the same problem the right side went out about 3 weeks ago. still waiting for the dealer to fix it. They had to order a new light, covered under warranty thankfully. I thought it was weird for a led to burn out so quickly so hopefully it was just a defect in the light but when they tried to sell me a comp werks tail light I noticed something weird about that one too. they had an 1199 with a comp werks light installed and after showing it to me and turning the bike off and taking the key out, one of the LEDs in the right tail light remained on for a good 5 minutes. Strange huh??? maybe it's a wiring issue from ducati's side??
The CW integrated tail light(s) have a parking feature that keep one LED lit up. Plural because I have the CW integrated tail light in my Monster and it keeps one lit up for about that amount of time.

Just confirming Jumpman's comment ^^^^^^
 
  • Like
Reactions: jumpman

·
Registered
Joined
·
23 Posts
Same happened to me...right side running rear light out. Thankfully a friend was following me and noticed it, otherwise I would have run out of warranty. **** thing cost over 500$. Sure hope the new one last more than 2k miles/2 years. Has anyone had any issues after getting it replaced.

-Brent
 

·
Registered
Joined
·
2 Posts
after market

do you have an aftermarket tail light kit? I put an aftermarket tail light from competition werks and my right side went out. It was a factory defect and they replaced it.
 
1 - 16 of 16 Posts
Top