Ducati 899 Panigale Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Long story short, was riding my bike and like a dumb dumb I stalled out at a light. It started back up but the check engine light came on. Drove it back home, didn't mess with it except check the code and it just said ENG. (real helpful). Later I took the battery out for a day just to see if it was just a glitch and would reset. Hooked it back up the next day and now it won't start, just clicks and the dashboard flashes and the fan comes on. Thought might be the battery, got a new one. Started for a second then died, went to start it again and I think I heard a pop. Now its back to just clicking. Read about the solenoid possibly being bad but I can't get to it to try and bypass it without taking off a radiator hose. Is it a good chance the solenoid is bad? I don't want to start taking it apart unless I know the issue and the the two dealerships I've dealt with are beyond incompetent and also over 2 hours away. Any insight would be greatly appreciated.
 

·
Registered
Joined
·
113 Posts
You are probably on the right track. Starting an engine requires power, a spark, fuel and air. In your case, even though you have a new battery, double check the voltage. Should be 12.6ish when resting. If that checks out then the clicking noise is most likely the solenoid. It’s also worth checking the wire connections, sometimes they Come loose.

If the problem were further upstream, like an engine issue or ecu... the bike would turn over but not fire up.
 
1 - 2 of 2 Posts
Top