Ducati 899 Panigale Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
So, my '15 899 has the dqs installed and it was on when I bought the bike. I turned it off and forgot about it for a couple years until I tried to activate it again-but its not there! I went into the R.M. menu and its usually there if you scroll through the options but not anymore. I tried resetting to Default all ride modes as well as disconnecting the battery and reconnecting it but its not there in the menu. I also disconnected the actual switch to the DQS shift rod and checked the function of the momentary switch-and it appears to work just fine.
Can anyone recommend a possible solution to relearn or tell the ECU the switch is there?

Thanks for the help!

Leif
 

·
Registered
Joined
·
11 Posts
Discussion Starter #2
Anybody have an idea? I have also checked the DQS switch and it functions correctly via tester off bike. No plug pins broken etc. I'm guessing the ECU "sees" the switch from an input and activates the menu item, correct?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
Thanks for the reply Axiomsl- regarding setting the DQS instructions in the owners manual. I've tried that...im familiar with using and programming the modes in the settings menu-already tried to activate it there, as I have before, but it simply does not show up, as usual. Like I said, I had programmed it OFF a while ago and went to program it back ON recently but it would not present itself. I checked the switch (the simple momentary switch) in the module AND the plug/connection but both are fine. Its a very simply device and I suspect the problem lies somewhere other than the switch or connection plug. I've also tried the key flip procedure (3X) on-of-on... to supposedly "hard reset" the "computer" to no avail. I dont want to take it to the dealer to diagnose of at all possible.
 

·
Registered
Joined
·
6 Posts
Hello
I am in the same boat. I had DQS on then the battery died. I put the new battery and went through the gear learning process and guess what DQS was not there anymore. I checked in the RM setting and it wasnt there too. Did you figure it out that what happened?
 

·
Registered
Joined
·
6 Posts
Thanks for the reply Axiomsl- regarding setting the DQS instructions in the owners manual. I've tried that...im familiar with using and programming the modes in the settings menu-already tried to activate it there, as I have before, but it simply does not show up, as usual. Like I said, I had programmed it OFF a while ago and went to program it back ON recently but it would not present itself. I checked the switch (the simple momentary switch) in the module AND the plug/connection but both are fine. Its a very simply device and I suspect the problem lies somewhere other than the switch or connection plug. I've also tried the key flip procedure (3X) on-of-on... to supposedly "hard reset" the "computer" to no avail. I dont want to take it to the dealer to diagnose of at all possible.
Hello
Did you find out the solution?
 
1 - 6 of 6 Posts
Top